Dodge SRT Viper Forums : ViperAlley banner
1 - 11 of 11 Posts

·
Premium Member
Joined
·
4,050 Posts
Discussion Starter · #1 ·
i just put in a set of NGK plugs, decided to then take this bucket for a spin; this thing is spitting, backfiring and popping like a Muther? this normal for NGKs? i wouldnt think so but figured id ask around befroe returning to champions.

reason i switched is i need a colder plug

sure hope i didnt just waste twenty minutes of my life putting these things in
 

·
Registered
Joined
·
38 Posts
When's the last time you changed your wires? Did you silicone the boots? Did you accidentally swap the wires? Check this first.

No, it's not normal for any car. Take them out and check the gap. If the gap's not a problem then check to see if you got the correct plugs for your car (compare them with the old plugs).
 

·
Premium Member
Joined
·
4,050 Posts
Discussion Starter · #3 ·
new magnecor wires two months ago. i thought i fucked up wires but ive checked twice and as many times as ive done my plugs im sure of them all correct. was running fine yesterday with the stock champions. guess ill keep looking
 

·
Registered
Joined
·
323 Posts
You may have used the wrong plugs. Here are the correct plug numbers:

FR5-1 = stock equivalent
BKR6E or BKR6EIX (iridium) = 1 step colder
BKR7E or BKR7EIX (iridium) = 2 steps colder

I was told by John (NGK Tech Support), that if you use a colder heat range for daily driving, it may cause the plugs to foul easily. Colder plugs are good for nitrous application.
 

·
Premium Member
Joined
·
4,050 Posts
Discussion Starter · #5 ·
i used ngk R5671A-7
 

·
Registered
Joined
·
723 Posts
Mojo call toofst, he tried a new autolite cold plug and he worked very well on the dyno. I believe the model # is 3923, but double check with him.

Isaac
 

·
Registered
Joined
·
10,727 Posts
PRVT JET said:
Mojo call toofst, he tried a new autolite cold plug and he worked very well on the dyno. I believe the model # is 3923, but double check with him.

Isaac
Isaac has the right number...I gap mine to 30 as opposed to 35 due to the N20...
 

·
Registered
Joined
·
7,340 Posts
It's probably just due to the colder plugs. I have those in my car for the nitrous. It sputters a bit, but they work well for nitrous.
 

·
Registered
Joined
·
323 Posts
Mojo - I'd pull those plugs out asap. If I remember correctly, that's the same plug # NX recommended to me initially. I called John/NGK to make sure, and he said it's the wrong plug. Call John/NGK at 877-473-6767, and he will tell you why it's the wrong plug (something to do with resistor and non-resistor type plugs that may cause PCM problems).
 

·
Registered
Joined
·
723 Posts
Thanks for verifying G, I will be doing mine soon. Toofst made 10rwhp more than me. The only difference was the plugs, same mods. we even had similar a/f ratio.
 

·
Premium Member
Joined
·
4,050 Posts
Discussion Starter · #11 ·
theyre resistor typre (hence the "R" designation)
 
1 - 11 of 11 Posts
Top