Dodge SRT Viper Forums : ViperAlley banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3,494 Posts
Discussion Starter · #1 ·
The local ******** were cracking us up last night. My car was running 11.2's on motor for several passes and everyone was saying the car should run low 10's on a 100 shot and low 9's on a 200 shot. Nothing like hangin' with some good ole boys for an ego boost.



But anyway I made 2 passes on the 100 shot and went 10.98 (1.86 60') at 133 and 10.82 (1.83 60') at 134. My NA mph was only 124 last night and it usually hits 127-128, but maybe it was the track. However I was pleased to see the 9 mph increase with a 100 shot. I am thinking it is making close to the 100 rwhp with that kind of jump in mph.


I seemed to get off the line ok, but right when the nos hit the drag radials didn't have a prayer. My nos is set to come in at 3000 rpms. I never did try to raise that to say maybe 3500 to see what happened.


Where do most people have their's hitting off the line? I guess most are running slicks/skinnies, but what should I try with drag radials?



John
 

·
Premium Member
Joined
·
4,050 Posts
john, the drag radials; they will hook and hold if theyre hot enough and low enough psi. set them at 15 and make surte theyre good and hot, you wont be disappointed believe me.

congrats on the juice run, fun aint it /images/graemlins/toothy
 

·
Registered
Joined
·
1,253 Posts
Nice runs. Especially 11.2s on motor (I'm not a huge nitrous fan). What have you done to the car to run low 11s n/a?

As far as the nitrous runs, your 60' says it all. If you drop at least a tenth off the 60', you'll be running mid-10s no problem. I agree with Mojo, get the DRs hot. I used to run BFGs on my Z06 with 15-17 psi and I'd cut 1.5X 60' regularly. Spend less time on the bottom of the track and you'll reap the rewards on the big end. Nice mph!!

Paul
 

·
Registered
Joined
·
3,474 Posts
John, I am glad to see you got that ignition problem figured out.

11.2 is great for heads/cam/no headers to say the least, 10.80's is good, but I am sure you will go slightly quicker with some sticky tires and the right RPM/clutch combination on the launch!
 

·
Registered
Joined
·
3,494 Posts
Discussion Starter · #6 ·
the car just has a set of heads and a mild cam in it.


My main concern was when the nos was hitting at 3000. It seemed the way I launch and right when the car hooks the nos kicked in and made the car spin wildly.


I had the tires at 17 which I normally have them at 15 but the track wasn't that great. I was cutting 1.70 60 without the nos but when I tried it the car spun. I launch from around 3500 slipping the clutch, but I guess I slip it to much OR need to drop my launch rpm a little OR raise the nos activation rpm.



I have run a 11.1 before with a high 1.7 60, so I think the car has a high 10 with a good launch.



Most days I seem to be a 12 second driver in a 10 second car!


John
 

·
Registered
Joined
·
1,253 Posts
Unfortunately, you'll just have to experiment and eventually you'll find the right combination. No magic recipe.

If nitrous kicks in at 3000 and you're launching at 3500 then are you spraying right off the line? If so, maybe try launching n/a and then hit the nitrous. You seem to be getting much better 60' when launching on motor alone.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top