Dodge SRT Viper Forums : ViperAlley banner

1 - 5 of 5 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
just picked up a theft recovery 2003 srt10. i have read as much as i can find on this issue . here are the facts. cold start no noise. once coolant temp gets to 200deg a come and go knocking noise starts to be heard. not constant but frequency does increase with rpm. oil psi is perfect, gage pined at almost 80 when cold and doesnt drop below 60 at hot idle. noise seems to disappear under hard acceleration or above 4k rpm. ive wasted $500 trying different oils. currantly running amsoil zee 20w50. does not mater if clutch is engaged or not. both valve covers removed, rolled push tubes over flat surface/all good. bench tested all 10 fuel injectors /all uniform and ohms the same. here is the thing.......when i unplug no. 3 fuel inj at idle .....noise stops. this being coupled with perfect steady oil pressure im suspecting wrist pin on no. 3. car has had 3500kms sence this issue was documented and doesnt seam to be getting worse. also all valve open/close distance was checked with dial ind. all uniform. what do i do next?
 

·
Registered
Joined
·
2,390 Posts
Drop the pan (easy) and windage tray... remove the rod cap on #3 and take a look. You can easily replace a rod bearing this way as well. Easy peasy.
 

·
Registered
Joined
·
3,121 Posts
Drop the pan (easy) and windage tray... remove the rod cap on #3 and take a look. You can easily replace a rod bearing this way as well. Easy peasy.
and... it should be done before the crank gets damaged or throw a rod by continuing to let it knock and degrade. (if the bearing is the cause)
 
1 - 5 of 5 Posts
Top