Dodge SRT Viper Forums : ViperAlley banner

41 - 60 of 63 Posts

·
Registered
Joined
·
3,705 Posts
Discussion Starter · #42 ·
Dan Cragin's shop is only a couple hour drive from A&C- why not move it over to them to finish the build?
Car's already home. I'll address anything else, and do the rest of the work myself. I trust myself not to screw me.
 
  • Like
Reactions: 99RT10&GTS

·
Registered
Joined
·
3,705 Posts
Discussion Starter · #43 ·
Got the oil results back from Blackstone. this should have been brand new oil, that I was charged for after the #2 valve job that never happened. Blackstone said it was likely redline oil and it had miles on it. I can therefore come to the conclusion that they kept my Motul oil, and billed me for new oil they never put in, after they never pulled the head. Oil was in the car when it was sold to the person I got it from. Also got billed for the "new" filter.
150412
150413
 

·
Registered
Joined
·
22,963 Posts
Damn
 

·
Registered
Joined
·
5,516 Posts
Very unfortunate and disappointing read. Hate to see owners go through this. Wish I could add something helpful :).You're not alone. I once had someone locally change out my spark plugs and change my fluids. When I got the bill I was WTF?!? They told me that I overtightened my plugs and they broke off upon removal, extra time, etc. They showed me the broken plugs...problem is they weren't my plugs. :D They're out there but I'm grateful that I'm knowledgeable, like you, to look for this. Most owners have no clue.
 

·
Registered
Joined
·
3,705 Posts
Discussion Starter · #47 · (Edited)
Did you get your oil filter analyzed?
Just cut the "new" filter open, and it's covered with some kind of soft stringy material, like thread tape. Must be what they make the "new" filters with! HAHAHAHA!!!
150416
150417
150418
 

·
Premium Member
Joined
·
19,047 Posts
This sucks. What a shit bag.
 
  • Like
Reactions: GRCFORCE327

·
Registered
Joined
·
3,705 Posts
Discussion Starter · #50 ·
Are you going to remove the filter pleats and pull them out flat? Would be curious to see what the inner and outer pleats captured.
I always do, but it's more than obvious that both filter and oil are not new.
 

·
Registered
Joined
·
3,705 Posts
Discussion Starter · #53 ·
Most don't mess with there oil pans, the small bolts are the weak 1/4-20 threads. As posted earlier, the a&c circus left a bolt out. I decided to replace the short pan bolts with studs, with the threads on the nut end being 1/4-28. Aids in lining up the pan on install, and still provides a clean look.
150448
 

·
Registered
Joined
·
3,705 Posts
Discussion Starter · #54 ·
You'll like this one. The harness for the sequential was already wired together with the indicator, and the a&c circus just had to wire to the Motec,(I provided the wiring diagram via Nth Moto). Looks like I got charged for "MOUNTING" the indicator. $35 for sticking it in the cup holder slot.
150477
150478
150479
 
  • Like
Reactions: plumcrazy

·
DEETOO
Joined
·
1,602 Posts
I like how the wire just gets pinched by the bezel with no relief or grommet. Good solution.
 

·
Registered
Joined
·
490 Posts
Todd has a pretty good reputation in the Viper Community. These claims seem out of character for his shop. Hope we can hear his side of the story.
 

·
Registered
Joined
·
3,705 Posts
Discussion Starter · #57 · (Edited)
Todd has a pretty good reputation in the Viper Community. These claims seem out of character for his shop. Hope we can hear his side of the story.
I'd love to see "words" trump "visual proof" ! You'd be surprised at the amount of people saying they also got screwed. Wish they would have posted their experience. I produce undeniable proof when I post. Just took the belly pan off, and a fuel line is pressing on the sequential shifter base. Common sense dictates that the line will develop a wear hole that could be a major disaster! Noticed the torque plate/spacer that comes with the poly mount wasn't installed. That may help.

150486
 

·
Registered
Joined
·
3,705 Posts
Discussion Starter · #58 · (Edited)
Got the torque plate in. Fuel line was still touching, so I wrapped it with a piece of hose. I'll check on it from time to time, but the plate did remove some of the force of it pushing against the shifter base.
150508
150509
 

·
Registered
Joined
·
3,705 Posts
Discussion Starter · #59 · (Edited)
Got the car to the point where I'm ok taking it for a drive. Now that's how a plug should look on E85(first pic). Now for the next issue to address. I sent the a&c circus a BBK throttle body to install. Todd said they couldn't get the car to idle properly, so they reinstalled the one that was on it. I let the car idle up to temp, and hit the throttle a few times, and the car idled fine(in the 850 range). Finally took it for a drive, and now the idle won't go below 1400 while driving. Got a new IAC and installed it yesterday. Idled up to temp just fine again, but have to wait on the weather to clear before driving. Old IAC and the port were black as was the vent to atmosphere filter.Cleaned the filter,but will probably run the vent to the intake piping and lose that ugly blue AN fitting. Also going to reinstall the BBK if the issue is corrected. The problem could also be in the programming, we shall see.
150575
150576
150577
 

·
Registered
Joined
·
3,705 Posts
Discussion Starter · #60 ·
Got the BBK throttle body out and the adjusting screw wasn't even touched! Blue glue mark wasn't broken and the blade gaps were ridiculous(first pics). I don't think they even tried to install it. Since the weather sucked, I went ahead and installed the BBK. Only thing that was a small battle, was getting the rubber over the larger opening. You can see by the pic of the clamps, the one closer to the TB tighten quicker, where as with the other TB, both clamps tightened to the same depth as the one further from the TB. Backed off the adjusting screw, and the car idles EXACTLY the same as the original TB(850 range). Still need to test drive again.

150578
150579
150581
 
  • Like
Reactions: plumcrazy
41 - 60 of 63 Posts
Top