01 GTS Wont start - Page 2 - Viper Alley - Dodge Viper Forum -SRT Viper
 
Go Back   Viper Alley - Dodge Viper Forum -SRT Viper » Viper Alley » Viper Discussions - Gen I & II
» Live Feed « · War Room · Graffiti Wall · Arcade · Viper Blogs ·  

Viper Discussions - Gen I & II Discussions of Viper-related subjects covering Gen-I and Gen-II models.

01 GTS Wont start

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Reply
 
Thread Tools Display Modes

Old October 6th, 2019, 03:32 PM   #21
Suspended
 
Lunchbox is offline
Join Date: Aug 2018
Location: Texas
Posts: 232
Lunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 points
Rep Power: 0
Ok, short update here for any that care and perhaps for someone down the road that may run into something similar.

Using the DRBIII I've been able to talk to the PCM,VTSS and the CCD Bus is good and communicating. Im also able to communicate with ABS/Airbag modules and no codes are present on any of the modules. I cannot however talk to the SKIM (SKM) Module at all. The VTSS states that everything is good but the engine is "not ok to start"

Since my ecu DID NOT have the vin programmed into it when i got it and i wanted to use the SCT To flash the ecu, i had to have my vin programmed into the ecu. In doing so, my theory is that the skim key/secret data is not synced with the ECU. However, not being able to communicate with the SKM is another story.

Do the SKM modules commonly fail or is this a rare occurrence?


EDIT:

Went and started checking all door lock switches, hood switches, hatch switch and found the hatch switch to be showing "CLOSED" on the DRB3 which was opposite of all the others when the doors and hood were closed. Tinkered with it and then found that i was able to get it to switched from CLOSED to OPEN. Guessing it just was stuck?! or maybe the gas shocks on it are slightly different that oem or adjustment needs to be made overall. Anyhow, it works now... Checked the VTSS Miscellaneous menu and the alarm monitor section and now the car states its OK to start after re-programming a FOB to the car then arming and dis-arming the alarm. Also need to check the VTSS Switch in center console for operability. It stated the same thing as the rear hatch switch but i had to run over to see family so i ran out of time.

Funny thing... ive never ever ever seen the red VTSS light on the dash flash when the car was locked/armed since i've owned it.... Now it does and i guess the alarm wasn't really working the whole time.

Anyway, went to start the car still nothing...

the body diagnostics manual makes mention that if you open the hatch and the hatch switch status says "closed" that you should replace the electronic entry module. Additionally, the PCM input/output status menu on the DRB3 is showing the theft alarm status as "seen". Unsure what this means... Im guessing it means its thinking its being stolen? I dont have any sort of lights flashing or horn going off so i have to believe its not tripped..

Last edited by Lunchbox; October 6th, 2019 at 08:45 PM.
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 

Old October 6th, 2019, 10:50 PM   #22
Landscaping Professional
 
GTS Dean's Avatar
 
GTS Dean is offline
Join Date: Jan 2003
Location: New Braunfels, Texas
Posts: 12,950
GTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 points
Rep Power: 411
Glad you are making some headway! Interestigly, the other day when I stopped by the house to get the DRB, a RAM pulled in my driveway just after I got in to leave. It was my old friend and first Viper Tech at the dealer I bought my 93, 96 wnd 03 from. He recently retired and just stopped by to say hi. If you need another experienced brain, he might be enticed to help.

Last edited by GTS Dean; October 6th, 2019 at 10:56 PM.
  Reply With Quote Quick reply to this message

Old October 6th, 2019, 11:23 PM   #23
Suspended
 
Lunchbox is offline
Join Date: Aug 2018
Location: Texas
Posts: 232
Lunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 points
Rep Power: 0
Quote:
Originally Posted by GTS Dean View Post
Glad you are making some headway! Interestigly, the other day when I stopped by the house to get the DRB, a RAM pulled in my driveway just after I got in to leave. It was my old friend and first Viper Tech at the dealer I bought my 93, 96 wnd 03 from. He recently retired and just stopped by to say hi. If you need another experienced brain, he might be enticed to help.
Took a little tinkering around to find a few other options in the menus but this thing is pretty nice to have! If you have some time, give him a shout for me and see if he is interested. If he is, i'm sure we can get ahold of each other and figure something out.

As for now, i'm thinking this is the keyless entry/alarm module but i think i'm going to do a bit more digging into the car tomorrow. Looks like the dis-arm switch in the center console does absolutely nothing for me and the DRBIII doesnt seem to pick up that its being toggled/turned. Since i don't know the full history of this car, i'm thinking someone may have been in there before possibly.
  Reply With Quote Quick reply to this message

Old October 7th, 2019, 01:18 PM   #24
Suspended
 
Lunchbox is offline
Join Date: Aug 2018
Location: Texas
Posts: 232
Lunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 points
Rep Power: 0
Well, spoke with dan and it was suggested i swap my pcm into another car to confirm and see if the problem follows.

If anyone around the austin area would like to try, im open to bring the PCM to you and we swap it out to see what comes of it. At the very least if it starts and runs in another car then i think the alarm may be partly at fault on my end here which helps narrow this all down.

Did the disarm vtss switch diagnosis in the body manual and the rear hatch switch diagnosis and found that it pointed me to to replace the Electronic entry module on two separate occasions... Really hoping the pcm swap works fine and then ill just replace the EEM and hopefully be done with these shenanigans and driving in this nice weather finally.

Last edited by Lunchbox; October 8th, 2019 at 11:32 AM.
  Reply With Quote Quick reply to this message

Old October 18th, 2019, 10:03 AM   #25
Suspended
 
Lunchbox is offline
Join Date: Aug 2018
Location: Texas
Posts: 232
Lunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 points
Rep Power: 0
Wasnt able to find someone to swap the pcm with but, i took a leap of faith here and i ordered a new EEM and keyfobs. Im not able to get the DRB3 to change the veh/theft status from seen to not seen with anything i do. Everything else checks out fine on the car however and looks entirely normal. EEM Should be here any day now. Special thanks to JonB at Viper parts rack america for this.
  Reply With Quote Quick reply to this message

Old October 21st, 2019, 06:02 PM   #26
Suspended
 
Lunchbox is offline
Join Date: Aug 2018
Location: Texas
Posts: 232
Lunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 points
Rep Power: 0
I just replaced the EEM (Electronic entry module) with a brand new NOS with new keyfobs that match it courtesy of viper parts rack and no change. Still no spark, no fuel and the engine only cranks but never starts.

So far ive replaced the CAM sensor (replaced it before i got ahold of a DRB3 to see the CKP Count)
EEM Has been replaced with a brand new (NOS) unit with matching key-fobs and they've been
programmed via the DRB3 and the car has been armed and un-armed (alarm DOES work and will trip)

Everything else on the car checks out and im a bit confused to say the least.

Last edited by Lunchbox; October 21st, 2019 at 11:19 PM.
  Reply With Quote Quick reply to this message

Old October 22nd, 2019, 07:12 PM   #27
Suspended
 
Lunchbox is offline
Join Date: Aug 2018
Location: Texas
Posts: 232
Lunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 pointsLunchbox made Varsity with 860 points
Rep Power: 0
It runs!

So i wasnt aware of this at first, but in the engine > dtc & monitors menu ( going frmo memory here) i was able to watch "secondary indicators" when trying to crank the engine. I hadn't seen this stuff at all before and started seeing some realtime DTCs show up finally!

I was getting p0210, p0209, and a few others. All the codes i did see were related to the injector control circuits.

So one of the things i decided to do was buy adapters that converted the stock injector clips to the right type of connector for the injectors im using in an effort to not hack up the stock wiring harness.

Come to find out, i pull off the adapters from the stock injector clips to the new injectors and looked carefully and found that the pins from the injector were sliding into the upper portion of the fuel injector clips where you would normally use a tiny flat head screw drive to release the wire with the crimped on terminal. Basically, they were not making any connection AT ALL. I was WAY too trusting of these things and was testing with them plugged in and saw that i wasnt getting an injector pulse when cranking much early on in the troubleshooting process. Had i tested them unplugged i would have seen the signal and figured this out much sooner.

I dropped the stock injectors back into the car and connected the oem injector connectors onto the injectors and the car fired right up...

I feel very stupid for not finding this much sooner, but lesson learned i guess. These adapters are going straight into the trash, i dont believe i have an recourse with returning these now since ive had them for a good part of a year now sitting around.

Last edited by Lunchbox; October 22nd, 2019 at 09:10 PM.
  Reply With Quote Quick reply to this message

Old October 23rd, 2019, 08:53 AM   #28
Landscaping Professional
 
GTS Dean's Avatar
 
GTS Dean is offline
Join Date: Jan 2003
Location: New Braunfels, Texas
Posts: 12,950
GTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 pointsGTS Dean is not afraid of bears with 58246 points
Rep Power: 411
That's great news Jeff! Sorry about your sunk cost in injectors, but your snake lives once more! Enjoy it for a while before you start into it again.
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Viper Alley - Dodge Viper Forum -SRT Viper » Viper Alley » Viper Discussions - Gen I & II

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Viper Alley - Dodge Viper Forum -SRT Viper forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes
Postbit Selector
Switch to Left (legacy) postbit Use Vertical (Legacy) Postbit

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




All times are GMT -5. The time now is 11:54 PM.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
ViperAlley.com is in no way affiliated with Daimler Chrysler. Dodge, Viper, RT/10, the Viper logo and likeness are registered trademarks of Daimler Chrysler.
The contents of this site are owned by ViperAlley.Com and may not be used or reproduced without the express written permission of the Administrator.