Viper Alley - Dodge Viper Forum -SRT Viper

Viper Alley - Dodge Viper Forum -SRT Viper (https://www.viperalley.com/forum/index.php)
-   Viper Discussions - Gen I & II (https://www.viperalley.com/forum/forumdisplay.php?f=9)
-   -   Power Steering pump help (https://www.viperalley.com/forum/showthread.php?t=296021)

CajunMojo August 18th, 2019 03:08 PM

Power Steering pump help
 
Is there a trick to getting the high pressure side hose off of the power steering pump? I'm trying to put a new power steering pump in and I can't get that bitch off.

Edit: Screw it, ordered another high side hose. I couldn't even get it off of the pump after I had it out of the car. I was hoping to be up and running today, but I guess I'll have to wait.

jslimm August 18th, 2019 08:33 PM

Quote:

Originally Posted by CajunMojo (Post 4676653)
Is there a trick to getting the high pressure side hose off of the power steering pump? I'm trying to put a new power steering pump in and I can't get that bitch off.

Edit: Screw it, ordered another high side hose. I couldn't even get it off of the pump after I had it out of the car. I was hoping to be up and running today, but I guess I'll have to wait.

Mine came off with no problem, no trick.

WDW MKR August 19th, 2019 09:41 PM

Quote:

Originally Posted by jslimm (Post 4676667)
Mine came off with no problem, no trick.



Same here... more than once.

Any signs of corrosion or other visual issues with your current pump/hose?


Sent from my iPad using Tapatalk

GTS Dean August 20th, 2019 08:07 AM

Be very careful about reinstalling the pump on the OE bracket. Be sure to torque down the 3 bolts evenly so as not to induce uneven stresses on the adapter boss to the head. This is a well known weak area on the Gen 1 & 2 cars.

CajunMojo August 20th, 2019 10:55 AM

Quote:

Originally Posted by GTS Dean (Post 4676783)
Be very careful about reinstalling the pump on the OE bracket. Be sure to torque down the 3 bolts evenly so as not to induce uneven stresses on the adapter boss to the head. This is a well known weak area on the Gen 1 & 2 cars.

Thanks for the tip. I should be putting it on today. I bought the ipsco bracket and pulley.

WDW MKR, no signs of corrosion, it just wouldn't come off. I ended up rounding off the nut.

CajunMojo August 20th, 2019 05:57 PM

Fuck... dumb question time. Does the hose go inside out outside of the drive belt? It looks like it would rub either way.

edit: i think i got it, Just had the hose cocked the wrong way when i tightened it down. Appears it's outside of the belt (i hope)

GTS Dean August 20th, 2019 08:22 PM

1 Attachment(s)
This way:

CajunMojo August 20th, 2019 09:34 PM

Got it. Thanks for all the help. It's been a month since I got to drive it, feel much better now.

Chuck 98 RT10 August 21st, 2019 08:27 AM

Quote:

Originally Posted by GTS Dean (Post 4676895)
This way:

Damn that's pretty. My engine would be that pretty if I didn't drive it so much. :D


All times are GMT -5. The time now is 06:06 AM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.3.2 ©2009, Crawlability, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
ViperAlley.com is in no way affiliated with Daimler Chrysler. Dodge, Viper, RT/10, the Viper logo and likeness are registered trademarks of Daimler Chrysler.
The contents of this site are owned by ViperAlley.Com and may not be used or reproduced without the express written permission of the Administrator.