Viper Alley - Dodge Viper Forum -SRT Viper - View Single Post - 01 GTS Wont start
View Single Post

Old October 6th, 2019, 03:32 PM   #21
Lunchbox
Suspended
 
Lunchbox is offline
Join Date: Aug 2018
Location: Texas
Posts: 589
Lunchbox is The Man with 2260 pointsLunchbox is The Man with 2260 pointsLunchbox is The Man with 2260 pointsLunchbox is The Man with 2260 pointsLunchbox is The Man with 2260 pointsLunchbox is The Man with 2260 pointsLunchbox is The Man with 2260 pointsLunchbox is The Man with 2260 pointsLunchbox is The Man with 2260 pointsLunchbox is The Man with 2260 pointsLunchbox is The Man with 2260 points
Rep Power: 0
Ok, short update here for any that care and perhaps for someone down the road that may run into something similar.

Using the DRBIII I've been able to talk to the PCM,VTSS and the CCD Bus is good and communicating. Im also able to communicate with ABS/Airbag modules and no codes are present on any of the modules. I cannot however talk to the SKIM (SKM) Module at all. The VTSS states that everything is good but the engine is "not ok to start"

Since my ecu DID NOT have the vin programmed into it when i got it and i wanted to use the SCT To flash the ecu, i had to have my vin programmed into the ecu. In doing so, my theory is that the skim key/secret data is not synced with the ECU. However, not being able to communicate with the SKM is another story.

Do the SKM modules commonly fail or is this a rare occurrence?


EDIT:

Went and started checking all door lock switches, hood switches, hatch switch and found the hatch switch to be showing "CLOSED" on the DRB3 which was opposite of all the others when the doors and hood were closed. Tinkered with it and then found that i was able to get it to switched from CLOSED to OPEN. Guessing it just was stuck?! or maybe the gas shocks on it are slightly different that oem or adjustment needs to be made overall. Anyhow, it works now... Checked the VTSS Miscellaneous menu and the alarm monitor section and now the car states its OK to start after re-programming a FOB to the car then arming and dis-arming the alarm. Also need to check the VTSS Switch in center console for operability. It stated the same thing as the rear hatch switch but i had to run over to see family so i ran out of time.

Funny thing... ive never ever ever seen the red VTSS light on the dash flash when the car was locked/armed since i've owned it.... Now it does and i guess the alarm wasn't really working the whole time.

Anyway, went to start the car still nothing...

the body diagnostics manual makes mention that if you open the hatch and the hatch switch status says "closed" that you should replace the electronic entry module. Additionally, the PCM input/output status menu on the DRB3 is showing the theft alarm status as "seen". Unsure what this means... Im guessing it means its thinking its being stolen? I dont have any sort of lights flashing or horn going off so i have to believe its not tripped..

Last edited by Lunchbox; October 6th, 2019 at 08:45 PM.
  Reply With Quote