Viper Alley - Dodge Viper Forum -SRT Viper - View Single Post - I need help
Thread: I need help
View Single Post

I need help
Old July 10th, 2019, 01:02 PM   #1
21Bubba
Senior Member
 
21Bubba is offline
Join Date: May 2012
Posts: 867
21Bubba is not afraid of bears with 9469 points21Bubba is not afraid of bears with 9469 points21Bubba is not afraid of bears with 9469 points21Bubba is not afraid of bears with 9469 points21Bubba is not afraid of bears with 9469 points21Bubba is not afraid of bears with 9469 points21Bubba is not afraid of bears with 9469 points21Bubba is not afraid of bears with 9469 points21Bubba is not afraid of bears with 9469 points21Bubba is not afraid of bears with 9469 points21Bubba is not afraid of bears with 9469 points
Rep Power: 72
I need help

I don't know where to start. But here goes.

Six years ago I bought mt 96 GTS. It had 11000 miles and was perfect. It now has 14000 miles. Yeah I know "drive the bitch" but that's part of the problem.

About three years ago I got stupid and attempted a burn out. Severe wheel hop and slight over rev.

Brought it home , raised it up and found I had cracked the bell housing. Got another one and while I was there changed the clutch for the hell of it.

Learned the mounts should be replaced and did that. Used wood house mounts. Buttoned everthing up and started it. This bitch vibrates so bad you can't touch the shifter. Saying WTF Got another set of poly mounts and put them in. Same shit. Took them out and put the original stock mounts back in. No vibration, happy days I thought.

Take the car out for a drive and at 3500 rpm guess what? This thing vibrates like a Hitachi.

Neutral or in gear (any gear) clutch in or out vibrates. Motor run fine, no noises, no misfires.

Now I'm not the manliest man but I'm not a puss either. When I say you can't hold the shifter I'm not exagerating. I've had solid mounts in cars before that never felt like this.
Just to be clear this a vibration not a shake. I'm out of ideas.
  Reply With Quote